Yocan Falcon not producing vapor

Post Reply
Posts: 3
Joined: Sun Nov 28, 2021 3:59 pm
United States of America

Yocan Falcon not producing vapor

Post by George0508 » Mon Dec 06, 2021 12:55 pm


I purchased a Yocan Falcon and cannot get smoke through the bubbler or the metal mouthpiece.

I filled the bowl about half full and tamped it lightly. I pressed the pre-heat button and waited while it pre-heated.

I then pressed the button and tried to inhale through the bubbler. It bubbled, but no vapor came through. I looked in the bowl and the material was partially burned and the container was too hot to touch.

I tried putting the stainless mouthpiece on and was still unable to get vapor.

I watched videos on YouTube and users seem, to generate large clouds easily. I can't even get a puff.

Do I need to completely fill the bowl? I am using the pancake could with dried flower ground to medium grit.

I am new to medical marijuana and need some help with this.

Thank you,
Hidden Content
This board requires you to be registered and logged-in to view hidden content.
User avatar
Posts: 525
Joined: Tue Dec 11, 2018 10:47 pm
United States of America

Re: Yocan Falcon not producing vapor

Post by Coco » Thu Dec 09, 2021 1:14 am

Sorry for the inconvenience. I think the vapor path was clogged, try to use the mini brush (come with the package) to clean the vapor path.
Collect all questions about Yocan, and 're-post' on this forum. Any question, please post it, our staff will response ASAP. Stay safe and healthy.
Post Reply

Return to “Yocan Falcon”